Поле валюта должно быть пустым

Поле валюта должно быть пустым

Запись не верна! Поле "Валюта" должно быть пустым!

Я
Himoza

После перехода с 1.6 на 2.0 при проведении некоторых документов Поступление товаров и услуг ругается "Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Журнал проводок(бухгалтерский и налоговый учет) Номер строки: 1)". При переносе валюты задвоились. Но есть копия данной базы, там тоже валюты задвоены но эти документы проводятся. Подскажите как исправить?

 
 

   Ногаминебить

Скорее всего не тот счет указан где-то в документе.

   Himoza

к меня на закладке услуги Счет затрат БУ и Счет затрат НУ указан 76.09 (счет не валютный). А на закладке счета расчетов указан 76.35(счет валютный).

Деноминация в 1С Бухгалтерия 8 для Беларуси (1.6)

Документ в EUR

   Himoza

я так понимаю это не правильно?

   СноваЗдорова

так и есть… указана валюта для счета, на котором не ведется валютный учет

   Himoza

но в версии 1.6 данный документ проводился с этими счетами

   СноваЗдорова

видимо там нет такой проверки

   Himoza

76.09 делать валютным?

   Himoza

как не охота план счетов в конфигураторе менять

   Ногаминебить

В обработке проведения добавить небольшую проверку и обнулять валюту.

   Himoza (9)
Если Проводка.СчетКт.Валютный Тогда Проводка.ВалютаКт = СтруктураШапкиДокумента.ВалютаВзаиморасчетов; Проводка.ВалютнаяСуммаКт = СтрокаТаблицы.СуммаВал; КонецЕсли; где-то тут.

Проверить если счет дебета не валютный, а счет кредита валютный? Мне надо чтобы сумма в проводке валютная была 
 

   Ногаминебить После ДвиженияПоРегистрам вставить обработку всех проводок.

Что-нибудь вроде Если (НЕ Проводка.СчетДт.Валютный) И (Проводка.ВалютнаяСуммаДт > 0) Тогда Проводка.ВалютнаяСуммаДт = 0; КонецЕсли; Если (НЕ Проводка.СчетКт.Валютный) И (Проводка.ВалютнаяСуммаКт > 0) Тогда Проводка.ВалютнаяСуммаКт = 0; КонецЕсли;

   Ногаминебить

(6) Подозреваю там как раз была проверка, но при переходе к более прогрессивной системе на нее забили. 🙂

   Himoza

(12) спасибо. сейчас попробую сделать

 

Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Запись не верна! Поле "Валюта" должно быть пустым!

Я
Himoza

После перехода с 1.6 на 2.0 при проведении некоторых документов Поступление товаров и услуг ругается "Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Журнал проводок(бухгалтерский и налоговый учет) Номер строки: 1)". При переносе валюты задвоились.

Ошибка при конвертации данных

Но есть копия данной базы, там тоже валюты задвоены но эти документы проводятся. Подскажите как исправить?

 
 

   Ногаминебить

Скорее всего не тот счет указан где-то в документе.

   Himoza

к меня на закладке услуги Счет затрат БУ и Счет затрат НУ указан 76.09 (счет не валютный). А на закладке счета расчетов указан 76.35(счет валютный). Документ в EUR

   Himoza

я так понимаю это не правильно?

   СноваЗдорова

так и есть… указана валюта для счета, на котором не ведется валютный учет

   Himoza

но в версии 1.6 данный документ проводился с этими счетами

   СноваЗдорова

видимо там нет такой проверки

   Himoza

76.09 делать валютным?

   Himoza

как не охота план счетов в конфигураторе менять

   Ногаминебить

В обработке проведения добавить небольшую проверку и обнулять валюту.

   Himoza (9)
Если Проводка.СчетКт.Валютный Тогда Проводка.ВалютаКт = СтруктураШапкиДокумента.ВалютаВзаиморасчетов; Проводка.ВалютнаяСуммаКт = СтрокаТаблицы.СуммаВал; КонецЕсли; где-то тут. Проверить если счет дебета не валютный, а счет кредита валютный? Мне надо чтобы сумма в проводке валютная была 
     Ногаминебить После ДвиженияПоРегистрам вставить обработку всех проводок. Что-нибудь вроде Если (НЕ Проводка.СчетДт.Валютный) И (Проводка.ВалютнаяСуммаДт > 0) Тогда Проводка.ВалютнаяСуммаДт = 0; КонецЕсли; Если (НЕ Проводка.СчетКт.Валютный) И (Проводка.ВалютнаяСуммаКт > 0) Тогда Проводка.ВалютнаяСуммаКт = 0; КонецЕсли;    Ногаминебить

(6) Подозреваю там как раз была проверка, но при переходе к более прогрессивной системе на нее забили. 🙂

   Himoza

(12) спасибо. сейчас попробую сделать

 

Наведи порядок в своей работе используя конфигурацию 1C "Управление IT-отделом 8"

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

   ReZеt Здравствуйте. При загрузке данных, из1С Предприятие 7.74.5(7.70.544) в Бухгалтерию предприятия 8.2 редакция 2.0 (2.0.37.14) Выдает следующую ошибку. ТипОбъекта= Операция (бухгалтерский и налоговый учет)Объект=Операция (бухгалтерский и налоговый учет) 00000000376 от 31.01.2012 0:00:00 ОписаниеОшибки=Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Подразделение" должно быть пустым! (Регистр бухгалтерии: Журнал проводок (бухгалтерский и налоговый учет); Номер строки: 1)
ПозицияМодуля=Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(4787)
КодСообщения=26
Для выгрузке данных из 7 использую модуль выгрузки данных (2.0.12).
Так вот что это? Я думаю что проблема в счёте так ли это? И скажите, как узнать, на какой именно операции происходит ошибка.
 
 
   iceman2112

А если попробывать ОбменДанным.Загрузка = Истина все равно не проходит?

   ICWiner

Капитан очевидность подсказывает, что проблема в документе "Операция (бухгалтерский и налоговый учет) 00000000376" от 31.01.2012 0:00:00. Конкретнее — "Поле "Подразделение" должно быть пустым!" Что тут не ясно?

   ReZеt

2 Ну да Ну понятно что поле а где в 7 найти ту запись в которой неверные данные Ну что править?

   iceman2112

Операции?????

   ICWiner

А если отладчиком пройтись и поставить остановку по ошибке?

   ReZеt

ICWiner щазззз буду пробывать

   ICWiner

(6) Я как-то сразу не допер, что там ошибка при записи уже в 8… А в отладчике даже если и не выцепишь какой док-т семерки, то будут счета, субконто, сумма. По этой информации, скорее всего, не сложно будет найти.

   ReZеt

iceman2112 Ну да Операция (бухгалтерский и налоговый учет)это бухгалтерская справка. Просто если обработка не загружает то я считаю это дело не в конфигураторе а если и в нем то в 7 ке ну и хочеться не меняя кода выявить ошибку и исправить её

   ReZеt

ICWiner Да я прекрасно вас понял, ) спасибо

   Дейл Используй старый дедовский способ Попытка Объект.Записать()Исключение
Сообщить(Объект)

И мне кажется счастье придет в твой комп
 
     Дейл

кстати попробуй при загрузки Оптимизацию  = ложь;

   ReZеt

Дейл огромное спасибо обязательно попробую

   ICWiner

(10) не поможет:) Он нам сообщит тот же "Операция (бухгалтерский и налоговый учет) 00000000376"

   GenV

(0) Хм. Вроде же ясно написано, что при записи операции в первой проводке не должно быть заполнено подразделение у одного из счетов. Т.е. у этого счета не стоит учет подразделениям.

   vitek89

Наверное по какому-то счету проводки нет учета по подразделениям. Надо посмотреть в правилах на стороне 7 , че туда пихается

   ReZеt

GenV вот и как узнать у какого счета нужно поставить учет по подразделениям

   ReZеt

ICWiner Верно не помогло

   vitek89

Можно же в плане счетов посмотреть, где есть учет по подразделениям, а где нет

   ReZеt

Ну я вроде как нашел 10.13 сделал учет по подразделениям но ошибка не осталась. Поэтому вот сижу и думаю как точно выципить по какому счёту вылазеет проблема.

при переносе из 77 в 8.2 поле валюта должно быть не заполнено

И что то ни как

   ReZеt

* осталась

   vitek89

Ну я имел ввиду выяснить что за счет, а потом в правилах конвертации отредактировать правило конвертации свойств, отвечающее за запись в подразделение, а не менять что-то в восьмерке.

   ReZеt

Ну да я и не хочу в 8 менять Такс загрузить правило конвертации

   ICWiner

В остановке по ошибке должна быть информация о проводке, которую пытается сформировать операция. Там и посмотри.

   ReZеt

ICWiner ок пробую

   GenV

(16) В модуле набора записей в 8 поставить точку, если выгружаешь не через COM.

   ReZеt

Так, сейчас дождусь ошибку и попробую ваш совет

 

TurboConf 5 — расширение возможностей Конфигуратора 1С

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *